Page 1 sur 1

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 10:21
par Rhiannon
Bonjour,

En testant mon site j'ai ce petit problème à résoudre concernant le sitemap.xml :

- code http 403 - acces refuse/exploration interdite

ce qui evidemment n'est pas super pour le referencement.

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 10:43
par Elodie
Bonjour,

Je viens de vérifier votre fichier sitemap.xml et il s'affiche bien chez moi.

Pourriez-vous m'indiquer l'adresse exacte où vous obtenez ce message d'erreur s'il vous plait ?

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 11:00
par Elodie
Par contre, je viens de voir que votre fichier .htaccess force l'accès sitemap.xml à être redirigé vers une extension PHP interne à votre site, alors que votre site dispose déjà d'un fichier sitemap.xml présent sur le disque.

Cette redirection charge à la volé l'ensemble de vos adresses apparemment sans aucun cache, occasionnant un certain délai le temps de chargement à chaque appel pour récupérer tous les liens de votre site.

Je vous recommande alors de désactiver la réécriture du "sitemap.xml" et d'ajouter une tâche cron sur le script PHP sitemap.php pour régénérer ce fichier toutes les 24 heures.

Ça aidera grandement à votre référencement.

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 11:21
par Rhiannon
alors c'est sûrement parce que j'ai changé le fichier, je l'avais généré en externe, là j'ai un logiciel sur le pc pour le faire.
par contre je vais enlever le sitemap.php et ce qui est sur le ht.access. c'est un module qui genere ça sur la librairie.

L'erreur m'a été signalée sur mon compte google, et d'ailleurs le fichier sitemap n'apparaissait pas lors des tests de referencement

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 12:02
par Elodie
rhiannon a écrit :L'erreur m'a été signalée sur mon compte google, et d'ailleurs le fichier sitemap n'apparaissait pas lors des tests de referencement
Que le fichier sitemap lui même ne soit pas référencé, ça peut être normal.

Est-ce que vous avez une date sur votre compte Google concernant ce message d'erreur s'il vous plait ? Je vois quelques 403 en Juillet (moins d'une dizaine) mais c'était des robots de SPAM d'adresses IP Russes. Je vois également sur la même période des erreurs 404 sur du sitemap.

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 12:09
par Rhiannon
elodie a écrit :
rhiannon a écrit :L'erreur m'a été signalée sur mon compte google, et d'ailleurs le fichier sitemap n'apparaissait pas lors des tests de referencement
Que le fichier sitemap lui même ne soit pas référencé, ça peut être normal.

Est-ce que vous avez une date sur votre compte Google concernant ce message d'erreur s'il vous plait ? Je vois quelques 403 en Juillet (moins d'une dizaine) mais c'était des robots de SPAM d'adresses IP Russes. Je vois également sur la même période des erreurs 404 sur du sitemap.
j'ai commencé à avoir des alertes en juillet mais je n'y ai pas vraiment pris garde j'étais un peu malade durant deux mois.

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 12:13
par Rhiannon
rhiannon a écrit :
elodie a écrit :
rhiannon a écrit :L'erreur m'a été signalée sur mon compte google, et d'ailleurs le fichier sitemap n'apparaissait pas lors des tests de referencement
Que le fichier sitemap lui même ne soit pas référencé, ça peut être normal.

Est-ce que vous avez une date sur votre compte Google concernant ce message d'erreur s'il vous plait ? Je vois quelques 403 en Juillet (moins d'une dizaine) mais c'était des robots de SPAM d'adresses IP Russes. Je vois également sur la même période des erreurs 404 sur du sitemap.
j'ai commencé à avoir des alertes en juillet mais je n'y ai pas vraiment pris garde j'étais un peu malade durant deux mois.
En fait il faut que je revois tout le header.tpl de la librairie, j'ai des alertes là dessus aussi mais le problème est que je n'y connais rien et que je ne sais pas du tout comment le rectifier. Du coup je cherche sur les forum, je ne comprends souvent pas les réponses ou bien j'applique une solution et je plante le site :(

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 12:39
par Elodie
rhiannon a écrit :En fait il faut que je revois tout le header.tpl de la librairie, j'ai des alertes là dessus aussi mais le problème est que je n'y connais rien et que je ne sais pas du tout comment le rectifier. Du coup je cherche sur les forum, je ne comprends souvent pas les réponses ou bien j'applique une solution et je plante le site :(
A ça, ça peut arriver à tous le monde. Comme on dit, c'est en forgeant que l'on devient forgeron ;)

La premier chose à faire, c'est de s'assurer que l'on dispose d'une sauvegardes, récente et valide, pour retomber sur nos pieds.

[Résolu] erreur 403 sur sitemap.xml

Posté : 8 octobre 2017 à 13:00
par Rhiannon
elodie a écrit :
rhiannon a écrit :En fait il faut que je revois tout le header.tpl de la librairie, j'ai des alertes là dessus aussi mais le problème est que je n'y connais rien et que je ne sais pas du tout comment le rectifier. Du coup je cherche sur les forum, je ne comprends souvent pas les réponses ou bien j'applique une solution et je plante le site :(
A ça, ça peut arriver à tous le monde. Comme on dit, c'est en forgeant que l'on devient forgeron ;)

La premier chose à faire, c'est de s'assurer que l'on dispose d'une sauvegardes, récente et valide, pour retomber sur nos pieds.
je fais mieux, avant même de faire une connerie, je sauvegarde lol
Merci Elodie, je vais continuer à forger ;)