[Résolu] Problème Mysql suite à changement de serveur

Un problème technique concernant l'utilisation d'un logiciel / CMS ou d'un service externe à FSH qui ne relève pas du support technique ? Vous pouvez vous entraider et échanger par l'intermédiaire de cette catégorie.
Répondre
Inconnu
Messages : 6508
Enregistré le : 29 décembre 2010 à 18:15

Bonjour
A la suite du changement de serveur et de version de Mysql, certaines requêtes qui fonctionnaient auparavant ne fonctionnent plus.
Par exemple :
$req1=mysql_query("INSERT INTO 'edthorairereeldavid' ('indexre', 'date', 'numligne', 'numcol', 'emploi') VALUES ( NULL ,'$datejr','$h','$i','$emploi')") or die ("Insertion des données impossible, erreur 1 ");
J'ai déjà fait plusieurs modifications pour tenter de trouver la bonne syntaxe mais je n'ai pas réussi pour l'instant.
Quelqu'un peut-il m'aider ?
Par avance, merci.
Claude Baisnée
Avatar du membre
Elodie
Messages : 7734
Enregistré le : 2 avril 2010 à 20:14

Bonjour,
cledtherve a écrit :$req1=mysql_query("INSERT INTO 'edthorairereeldavid' ('indexre', 'date', 'numligne', 'numcol', 'emploi') VALUES ( NULL ,'$datejr','$h','$i','$emploi')") or die ("Insertion des données impossible, erreur 1 ");
Les auto incrément ne sont pas à définir dans une requête SQL. J'imagine alors que 'indexre' est un auto incrément ? Si oui, retirez-le ainsi que son "NULL" correspondant.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Inconnu
Messages : 6508
Enregistré le : 29 décembre 2010 à 18:15

Vous avez tout à fait raison, indexre est un auto-increment et la requête corrigée selon votre conseil fonctionne. Merci beaucoup.
Répondre