Problème mails

Quelque chose ne fonctionne pas alors qu'il vous semble que le soucis ne vient pas de vous ? Vous avez des questions sur nos services et vous pensez que vos préoccupation peuvent intéresser d'autres hébergés ? N'hésitez pas à nous contacter.
Répondre
Lovpuppy
Messages : 143
Enregistré le : 11 avril 2012 à 13:56

Bonjour
Certains de mes clients se plaignent que les mails qui leur parviennent par l'intermédiaire de leur site ne porte pas l'indication de l'envoyeur qui est rebaptisé.
J'utilise uniquement le formulaire du core JOOMLA sans modification (qui nécéssiterait un override) et sans possibilité de changer le paramétrage.
Ce problème n'existe pas chez d'autres hébergeurs avec le même réglage et devient problèmatique pour certaines typologies de clients (hôtels) qui ne savent pas qui réserve ....
S'il existe une procédure de modification au niveau hébergement, merci de me la décrire.
Bien cordialement
Avatar du membre
Elodie
Messages : 7719
Enregistré le : 2 avril 2010 à 20:14

Bonjour,

FSH protège et évite l'usurpation d'identité en interdisant l'envoi de mails de la part d'un expéditeur autre qu'un expéditeur vérifié d'où provient le mail. Par exemple, il n'est pas possible d'envoyer un mail avec le champ expéditeur "From: contact@banque-france.fr" si le service mail de la banque de France n'est pas géré par notre plateforme mail et que le compte client d'où provient le mail n'est pas gestionnaire du nom de domaine.

Ceci est en place pour éviter le phishing et garantir la bonne qualité de délivrabilité de nos envois mails chez nos destinataires respectifs tout en utilisant les entêtes mail selon leurs usages. Tout comme l'envoi d'un mail après s'être authentifié par SMTP.

Pour les formulaires de contact, le mail n'est pas envoyé par l'internaute, mais par le site lui-même à la demande de l'internaute, d'où la présence de cette règle. Si vous souhaitez savoir qui à fait envoyer le mail depuis votre site et à qui répondre, il faut utiliser le champ "reply-to:" qui correspond à la norme RFC 4021 (https://tools.ietf.org/html/rfc4021#page-8).

Le "reply-to:" est la norme à utiliser, si Joomla ne le permet pas dans le formulaire de contact, c'est un problème dans le thème utilisé ou un bug Joomla comme à l'époque pour sa version 1.7.

Un Développeur sur Joomla en parle en 2014 ici : https://forum.joomla.org/viewtopic.php? ... 1#p3246521 et il dit dans son message qu'à ce moment-là Gmail ne respectait pas la RFC. Depuis, espérons que c'est corrigé chez Gmail et que vous utilisez une version à jour de Joomla.

Si vous utilisez la dernière version de Joomla et que le problème est toujours présent (et pas que via Gmail), il vous faudrait vérifier votre thème graphique et/ou contacter la communauté Joomla pour avoir la possibilité d'utiliser le champ "reply-to:" dans vos formulaires de contact, comme ça devrait être.

https://www.franceserv.fr/wiki/mail#eme ... xpeditrice
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Lovpuppy
Messages : 143
Enregistré le : 11 avril 2012 à 13:56

Merci pour votre réponse qui, malheureusement ne règle en aucun cas le problème.
Pour votre information, je gère environ 200 sites JOOMLA dont une cinquantaine hébergés chez vous et j'utilise environ 150 templates différents dont certains sur un site hébergé chez vous et un autre hébergé ailleurs.
Hors le problème n'existe que chez FSH TOUS les autres hébergeurs ayant paramétré leurs serveurs pour permettre au destinataire du mail de savoir qui lui envoie .....
Même si je comprend votre souci d'éviter le pishing, vous devez aussi comprendre que votre réglage rend inutilisable certains de mes sites (expliquez moi comment fait un hôtel pour répondre à une réservation dont il ne connait pas l'émetteur !)
Plusieurs fois déjà j'ai attiré votre attention sur le problème qui reste constant quelque soit la version de JOOMLA utilisée et dont le non réglement par vos soins m'aménerais, à ma grande désolation, à migrer mes sites sur un hébergement plus fonctionnel.
Je compte sur vous ....
Avatar du membre
Elodie
Messages : 7719
Enregistré le : 2 avril 2010 à 20:14

Par quelle méthode envoyez-vous les mails, via sendmail() de PHP ou via authentification SMTP ?

PS. Si d'autres hébergeurs font les choses incorrectement et que ça rend fonctionnel un bug de développement ou un paramétrage Joomla incorrect, je ne casserai pas une norme RFC et la sécurité de mes services.

Edit: Comme vu par téléphone à l'instant, je vous ai proposé d'envoyer vos mails via l'authentification SMTP afin de se baser exclusivement sur ce protocole avec des mécanismes pouvant être mieux géré par Joomla. Nous verrons si cela corrige votre problème.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Lovpuppy
Messages : 143
Enregistré le : 11 avril 2012 à 13:56

Effectivement ça marche en passant par l'identification SMTP.
Encore merci Elodie ....
Avatar du membre
Elodie
Messages : 7719
Enregistré le : 2 avril 2010 à 20:14

lovpuppy a écrit :Effectivement ça marche en passant par l'identification SMTP.
Encore merci Elodie ....
D'accord, je suis contente que ça a pu résoudre votre problème, MAIS je viens de tester un Joomla de base sans avoir à utiliser l'authentification SMTP et ça fonctionne parfaitement.

J'ai installé la dernière version Joomla 3.9.26 avec la configuration par défaut (avec PHP Mail) ayant comme adresse d'expédition "admin@franceserv.fr", puis j'ai défini l'adresse "contact@franceserv.fr" où je veux recevoir les mails des internautes (vos réservations d'hôtel dans votre cas) :

Image

Et j'ai testé le formulaire de contact en tant qu'internaute depuis un autre navigateur et une autre IP :

Image

Et ça à parfaitement fonctionné :

Image

L'adresse de l'expéditeur qui était "admin@franceserv.fr" a été réécrite par l'adresse par défaut du compte en "elodie@franceserv.com" où le site test se trouve, car ce site n'a pas l'autorisation d'usurper l'adresse "admin@franceserv.fr". ET l'adresse de l'internaute se trouve dans le champ "Réponse à" qui est en anglais le "reply-to:" :

Image

Le lien du site Joomla sans aucune modification, uniquement du Core :
http://test202105.franceserv.com/index. ... contact-us

Et l'envoi du mail a bien été effectué via PHP avec une réécriture du champ expéditeur notifié :

Image

Du coup, je ne comprends pas votre problème, il vous faut vérifier vos paramètres Joomla et voir avec leur équipe s'il a été modifié, car de base (rien qu'avec du Core), ça fonctionne parfaitement.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Répondre