[Résolu] Nextcloud

Quelque chose ne fonctionne pas alors qu'il vous semble que le soucis ne vient pas de vous ? Vous avez des questions sur nos services et vous pensez que vos préoccupation peuvent intéresser d'autres hébergés ? N'hésitez pas à nous contacter.
Anca
Messages : 31
Inscription : 29 octobre 2012 à 07:48

Bonsoir c'est re moi :D

l'activation du HSTS c'est bon
Le problème d'intégrité des fichiers c'est bon aussi: il fallait régler le type de transfert ftp en binaire et upload les fichiers corrompus (je lis la doc je ne sais combien de fois, c'est devant moi et je percute pas => Warning, boulet détecté :o)

Niveau configuration il y a 2 problèmes:

=>Aucun cache mémoire n'est configuré. Si possible, configurez un "memcache" pour améliorer les performances. Pour plus d'informations consultez la documentation.

là je sais pas quoi faire

=>Le PHP OPcache n'est pas correctement configuré. Pour de meilleure performance nous recommandons d'utiliser les paramètres suivant dans le php.ini :
opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1
donc je crée un php.ini à la racine du site avec les paramètres et ca marche pas :/

Donc je me demandais si vous pouviez m'expliquer la manip à faire pour le memcache et pourquoi mon php.ini ne fonctionne pas?

S'iouplait
Avatar de l’utilisateur
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7865
Inscription : 2 avril 2010 à 20:14

anca a écrit :=>Aucun cache mémoire n'est configuré. Si possible, configurez un "memcache" pour améliorer les performances. Pour plus d'informations consultez la documentation.

là je sais pas quoi faire
Pour accéder à votre instance memcache, il vous faut utiliser le socket /tmp/httpd/memcache/example.socket en remplaçant "example" par votre identifiant seul. Après, pour configurer la solution web que vous avez choisie, il vous faut consulter leur documentation car je ne sais pas ce que vous utilisez.
anca a écrit :=>Le PHP OPcache n'est pas correctement configuré. Pour de meilleure performance nous recommandons d'utiliser les paramètres suivant dans le php.ini :

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1
J'aimerai bien savoir pourquoi ils considèrent que OPCache n'est pas correctement configuré :)

Quelle version PHP utilisez-vous s'il vous plait ? Les valeurs recommandées sont celles que j'utilise excepté pour le memory_consumption qui est configuré à 1 Go au lieu de 128 Mo en rapport avec la capacité maximale de la RAM que permet un nœud Web. Le revalidate_freq est de 30 secondes par défaut car j'estime qu'un cache fichier d'une seule seconde est inutile, voir contre productif.
anca a écrit :donc je crée un php.ini à la racine du site avec les paramètres et ca marche pas :/
Il y a 2 choses à savoir :

1) Ça ne fonctionne pas car le nom de ce fichier n'est pas forcement "php.ini" coté utilisateur. Le nom original et par défaut de ce fichier est ".user.ini". Chez FranceServ Hébergement, il faut utiliser le nom de fichier ".php.ini" comme indiqué dans la documentation https://www.franceserv.fr/wiki/php et https://phpinfo.franceserv.fr/

J'ai choisie de garder le point initial avant php.ini pour rester dans l'optique de la sécurité, mais aussi pour éviter de charger des fichiers PHP personnalisés inutilement, parfois superflues voir même non optimisés par rapports à la configuration matérielle.

2) Les directives opcache ne peuvent pas toutes fonctionner dans le ".user.ini" car elles ne peuvent pas toutes être modifiées. Se reporter à la documentation : http://php.net/manual/en/opcache.configuration.php où seuls PHP_INI_ALL et PHP_INI_USER sont accessibles.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Anca
Messages : 31
Inscription : 29 octobre 2012 à 07:48

J'utilise la version php 7.0

Pour le memcache je sais pas faire mais j'aimerais bien savoir

En ce qui concerne php.ini:
la doc de Nextcloud me renvoit vers la doc que vous avez cité et à cette doc

On parle bien du php.ini et donc du .php.ini pour l'hébergement Franceserv. Mon .user.ini ne permet pas a toutes les directives opcache de fonctionner donc, pour cette situation il ne me sert à rien.


https://nuage.peinard.net/info.php


A demain pour de nouvelles aventures :)
Anca
Messages : 31
Inscription : 29 octobre 2012 à 07:48

Bonjour,

j'ai toujours le problème suivant:

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

un coup de main svp?

Cordialement
Avatar de l’utilisateur
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7865
Inscription : 2 avril 2010 à 20:14

Bonjour,

OpCache est déjà actif et optimisé, il vous faut alors soit ignorer cette recommandation, soit mettre les lignes qui sont personnalisables dans un fichier .php.ini comme expliqué précédemment. Mais définir revalidate_freq à 1 sera moins optimisé que présentement.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Anca
Messages : 31
Inscription : 29 octobre 2012 à 07:48

Bonjour,

j'ai déjà fait la procédure que vous m'avez indiqué: je l'ai mis à la racine du site et rien; c'est quasi instantané donc si ca marche j'ai juste à recharger la page et je vois si c'est fonctionnelle. Le fichier s'appelle bien .php.ini.
edit1: Je viens de refaire la manip, re upload et ctrl+f5 : toujours le même msg d'erreur

edit2: je retire opcache.revalidate_freq=1
Avatar de l’utilisateur
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7865
Inscription : 2 avril 2010 à 20:14

anca a écrit :j'ai déjà fait la procédure que vous m'avez indiqué: je l'ai mis à la racine du site et rien; c'est quasi instantané donc si ca marche j'ai juste à recharger la page et je vois si c'est fonctionnelle. Le fichier s'appelle bien .php.ini.
Toutes les valeurs que vous avez définies sont des valeurs PHP_INI_SYSTEM, donc non modifiables de votre coté car elles sont configurées par rapport aux caractéristiques (RAM et processeurs) du nœud Web de l'hébergement mutualisé et elles sont correctement définies par rapport au matériel.

Vous ne pouvez modifier que les valeurs PHP_INI_ALL et PHP_INI_USER, merci alors de vous reporter au lien que je vous ai indiqué précédemment pour déterminer quelles valeurs sont personnalisables : http://php.net/manual/en/opcache.configuration.php

Par exemple, vous ne pouvez pas changer l'usage maximal de la RAM qui est de 1 Gb en mettant 128 Mb seulement, ou encore le nombre de fichiers pouvant être stockés en RAM.

Voici un aperçu de l'usage d'OpCache sur PHP 7.0 du nœud Web1 :

Image

On peut voir que 55% de 1 Gb est utilisé, soit environ 563 Mb. Vous ne pouvez donc pas définir 128 Mb car d'autres hébergés utilisent ce cache et ils ne seraient probablement pas content :) Le cache est correctement configuré car ça Hit à 96%.

Il vous faut alors ignorer ces recommandations NextCloud, peut être ont t-ils même prévus un moyen pour désactiver ces recommandations ? Il faudrait voir ça avec eux, je vois qu'ils utilisent une fonction de nom "isOpcacheProperlySetup". Vous pourriez aussi commenter les lignes 157 à 168 du fichier JavaScript ./core/js/setupchecks.js en brut pour éviter ces messages cotés navigateur.

Concernant opcache.revalidate_freq, le définir à 1 est d'après moi contre productif. Par défaut je l'ai défini à 30 secondes.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Anca
Messages : 31
Inscription : 29 octobre 2012 à 07:48

ok merci pour la réponse je passe en résolu
bonne soirée
Avatar de l’utilisateur
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7865
Inscription : 2 avril 2010 à 20:14

Merci, bonne soirée de même :)
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Répondre