[Résolu] PHP limité ?

Quelque chose ne fonctionne pas alors qu'il vous semble que le soucis ne vient pas de vous ? Vous avez des questions sur nos services et vous pensez que vos préoccupation peuvent intéresser d'autres hébergés ? N'hésitez pas à nous contacter.
Répondre
Past-rss
Messages : 25
Enregistré le : 12 mai 2011 à 11:11

Bonjour bonjour,

PHP ne semble pas construire ma page en entier.
Il s'arrête à moitié : est-ce un bug ? Une limitation ?
https://divsplay.com/user/demo/edit.php

Précisions utiles :
- PHP 7.04 en local PHP 7.3 paramétré sur le serveur
(mais je n'ai rien changé au code PHP qui marchait bien il y a quelques mois, dans les mêmes conditions)
- messages d'erreurs demandés, mais aucun n'apparaît

- j'ai eu des soucis de dépassement de mon forfait FTP :
> 2 prestashops installés : dépassement, j'en ai enlevé un
> bug des emails de mon provider (pop3) : je viens de recevoir 101 vieux messages d'un coup !
> parmi ceux-ci, il y avait 13 messages [Administratif/Technique] Votre espace FTP est utilise a 100%
suivis chacun par 13 messages [Administratif/Technique] Votre espace FTP n'est plus utilise a 100%
> j'ai donc rallongé mon espace FTP et n'en suis plus qu'à 84%
> peut-être ces alertes ont été suivies de limitations PHP que l'on pourrait lever, à présent
> si ce n'est pas ça... je ne vois pas ! ;-)

Merci d'avance, pour tout
Avatar du membre
Elodie
Messages : 7767
Enregistré le : 2 avril 2010 à 20:14

Bonjour,

Il n'y a pas de limitation de ce style, je pense plus à une erreur PHP avec un message d'erreur qui ne s'affiche pas car désactivé.

Je vous propose alors de loguer les éventuelles erreurs PHP ainsi pour le développement :

Code : Tout sélectionner

ini_set('display_errors', 1);
Ou pour de la production sans afficher au grand jour les éventuelles erreurs :

Code : Tout sélectionner

ini_set('error_log', 'errors.txt');
ini_set('log_errors', 1);
Pensez à spécifier ces lignes au tout début du script PHP et vérifier qu'aucun traitement ultérieur effectue l'inverse.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Past-rss
Messages : 25
Enregistré le : 12 mai 2011 à 11:11

D'accord, on va faire ça...

Merci !
Avatar du membre
Elodie
Messages : 7767
Enregistré le : 2 avril 2010 à 20:14

J'ai regardé très rapidement votre script PHP et le premier include mène à un fichier HTML qui a été modifié il y a 3 jours ce 6 février (envoyé par FTP) et sa fin semble tronquée.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Past-rss
Messages : 25
Enregistré le : 12 mai 2011 à 11:11

Mille merci ! Le problème venait bien de là.

J'ai dû m'absenter 2 jours, puis j'ai installé PHP v7.3.21 en local (PHP 7.3 sur FranceServ)
...et même problème ! (alors que mon code marchait sur toutes les versions de PHP, en local)
Pourtant j'avais bien renvoyé (et écrasé) plusieurs fois tous les fichiers de chacun des dossiers.

Suite à votre commentaire (très gentil de faire cet effort pour moi !), j'ai relancé un upload de ce fichier spécifique vers le serveur... et même souci : l'original faisait 38 ko, le destinataire 16 ko !
J'ai renommé le destinataire, et renvoyé l'original : idem.
J'ai supprimé tous les fichiers du dossier puis les ai tous renvoyés : ça marche !

C'est donc un problème de Fillezilla FTP (dernière version).
Peut-être le fait que le nom du fichier comporte 2 points ?
(ex: fichier.inc.htm. Sachant que mon fichier.incold.htm renommé posait aussi un problème)

En tout cas, encore merci : je vais pouvoir poursuivre sereinement. :)
Répondre