PHP 7.4

Quelque chose ne fonctionne pas alors qu'il vous semble que le soucis ne vient pas de vous ? Vous avez des questions sur nos services et vous pensez que vos préoccupation peuvent intéresser d'autres hébergés ? N'hésitez pas à nous contacter.
Répondre
Rhiannon
Messages : 240
Enregistré le : 22 août 2010 à 12:42

Bonjour,

Il m'était conseillé de mettre à jour sur PHP 7.4 (j'étais en 7.3), je l'ai fait et bien sûr j'ai ce message qui apparaît côté public :
Unsupported PHP Version
Opencart 3.0.3.6 does not fully support PHP 7.4.20 version!

Consult with your hosting provider for more information regarding how to downgrade PHP to 7.3 (or lower).

Donc je suis retournée pour repasser en 7.3 et..... mon site affiche toujours le même message : il est planté!!! :diable: La version d'odyssee est la plus récente, alors si elle ne supporte pas le 7.4 je suis mal.

Par contre côté admin ça a l'air de fonctionner, mais si mes clients pouvaient acceder à la librairie ce serait mieux :pleur4:

Merci
Rhiannon
Messages : 240
Enregistré le : 22 août 2010 à 12:42

ça y est, le site est revenu à la normale mais en PHP 7.3
Avatar du membre
Elodie
Messages : 7725
Enregistré le : 2 avril 2010 à 20:14

Bonsoir,

Il faut savoir qu'il y a un délai maximum de 5 minutes à attendre lorsque l'on change de branche PHP via le gestionnaire client, d'où le message d'erreur encore présent pendant ce délai.

Avant de changer la branche PHP de son site Internet, il faut s'assurer que son site Internet est à jour et compatible. Mais on peut très bien essayer et revenir en arrière si ça ne fonctionne pas correctement.

La branche PHP 7.3 arrive en fin de vie en décembre 2021, mais d'après une recherche sur le forum de OpenCart, ce message d'erreur ne vient pas d'eux même, mais du thème graphique utilisé et OpenCart serai bien compatible PHP 7.4.

D'après le sujet de discussion suivant : https://forum.opencart.com/viewtopic.php?t=220335 la faute reviendrai à "Journal3" où il est dit que "Journal3 is one of the worst OpenCart extensions, it's not a proper standard-compliant theme!".

On voit dans cette même discussion qu'il serait possible de "masquer" ce message d'erreur non officiel en éditant un fichier. À voir s'il n'y a pas d'autres problèmes après. Vous pouvez aussi vérifier si votre thème est à jour ou le corriger en prenant soins d'avoir une sauvegarde de ce que vous modifiez.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Répondre