Memcached - Cache Objet

Quelque chose ne fonctionne pas alors qu'il vous semble que le soucis ne vient pas de vous ? Vous avez des questions sur nos services et vous pensez que vos préoccupation peuvent intéresser d'autres hébergés ? N'hésitez pas à nous contacter.
Danceranic
Messages : 21
Inscription : 31 mai 2018 à 13:28

Bonjour Elodie

J'ai installé un plugin de cache objet persistant
(Object Cache 4 everyone)

La configuration par défaut est :

$memcached_servers = array(
'default' => array(
'127.0.0.1:11211' // Remplacez par l'adresse IP et le port fournis par votre hébergeur
)
);


Pourriez vous me donner la configuration à indiquer pour serveur mutualisé.
Merci
Avatar de l’utilisateur
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7937
Inscription : 2 avril 2010 à 20:14

Bonjour,

Memcache est présent via un fichier de type socks dans le chroot de l'hébergé. Pour le port, on peut mettre le port 0 derrière une virgule comme ceci :

Code : Tout sélectionner

/var/run/memcached.sock, 0
Votre code devrait alors ressembler à ceci :

Code : Tout sélectionner

$memcached_servers = array(
'default' => array(
'/var/run/memcached.sock, 0' // Remplacez par l'adresse IP et le port fournis par votre hébergeur
)
);
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Danceranic
Messages : 21
Inscription : 31 mai 2018 à 13:28

"Since 1.4, you can declare your own Memcached Server instance in the wp-config.php file.
Example:
define(‘OC4EVERYONE_MEMCACHED_SERVER’, ‘127.0.0.1:11211’);

Starting from version 1.6, you have the option to declare in the wp-config.php file whether you want to use the external disk object cache in case the Memcached Server is not present.
Outdated or malfunctioning disks can negatively impact website performance.
Example:
define(‘OC4EVERYONE_DISABLE_DISK_CACHE’, true);"

J'ai donc essayer dans wp-config.php
define(‘OC4EVERYONE_MEMCACHED_SERVER’, ‘/var/run/memcached.sock, 0’);

Site planté.
J'ai supprimé.

Par default,
$memcached_servers = array(
'default' => array(
'127.0.0.1:11211' // Remplacez par l'adresse IP et le port fournis par votre hébergeur
)
); semble fonctionner mais c'est cette adresse 127.0.0.1 qui me chiffonne.

Ca a l'air de fonctionner ainsi enfin mieux qu'hier...Un avis ?
Avatar de l’utilisateur
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7937
Inscription : 2 avril 2010 à 20:14

J'ai coupé ce process en localhost, il n'est pas à utiliser pour des raisons de sécurité.

Il vous faut utiliser le chemin dans votre espace personnel. Si ça ne fonctionne pas, il vous faudra contacter le développeur de votre extension afin de savoir comment procéder.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Répondre