Annonce

Lorsque vous exposez un problème que vous rencontrez sur votre site, n’omettez pas de bien préciser l’adresse de la page (URL) concernée.

Ouvrez un nouveau sujet de discussion pour poser une question, n'utilisez pas une discussion déjà ouverte si votre problème est différent.
Lorsque votre sujet est résolu, indiquez-le en modifiant votre premier message et en ajoutant "[Résolu] " au début du sujet.

Pour les possesseurs de sites Minecraft : Tous les ports TCP/UDP en sortie sont ouverts.
Pour en savoir plus : https://www.franceserv.fr/wiki/minecraft

#1 27/12/2016 11:31:09

lejardindesroses
Membre
Inscription : 21/02/2015
Messages : 5

[Résolu] Piwik - affichage de l'interface

Bonjour,

Depuis peu, piwik me pose un problème en ne chargeant pas les fichiers CSS de l'interface. Donc Piwik s'affiche correctement mais de manière "brut".

Il m'est donc impossible de l'utiliser correctement.
Est-ce que mon hébergement pourrait affecter l'affichage CSS ?
Précision : j'utilise l'outil de mise à jour automatique de piwik.

Merci d'avance pour votre aide.

Dernière modification par lejardindesroses (05/01/2017 12:28:21)

Hors ligne

#2 27/12/2016 12:32:49

elodie
Responsable/CEO FranceServ Hébergement
Lieu : Jura
Inscription : 02/04/2010
Messages : 6 883
Site Web

Re : [Résolu] Piwik - affichage de l'interface

Bonjour,

lejardindesroses a écrit :

Depuis peu, piwik me pose un problème en ne chargeant pas les fichiers CSS de l'interface. Donc Piwik s'affiche correctement mais de manière "brut".

Je viens de regarder 2 ou 3 pages de votre site et je ne pense pas voir de problème, peut être avez-vous déjà résolu le problème ou alors le problème vient de votre navigateur Internet (par exemple une extension anti-pub qui bloquerai à tord vos feuilles de styles ?

lejardindesroses a écrit :

Est-ce que mon hébergement pourrait affecter l'affichage CSS ?

Les feuilles de styles CSS, HTML et Scripts JS étant interprétés directement sur le navigateur Internet et non pas par le moteur (PHP) du serveur, l'hébergement ne peut pas interférer en lui même sur cette partie.

N'hésitez pas à vérifier avec un autre navigateur Internet ou à me faire parvenir une capture écran du problème car je ne pense pas qu'il y en ai un présentement sur votre site.


P8OdseCN.gifVous avez une question ?

Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, utilisez alors dans ce cas le formulaire de contact pour me joindre.

Hors ligne

#3 27/12/2016 12:38:43

elodie
Responsable/CEO FranceServ Hébergement
Lieu : Jura
Inscription : 02/04/2010
Messages : 6 883
Site Web

Re : [Résolu] Piwik - affichage de l'interface

Par contre, je viens de voir que vous avez activé la prise en charge SSL sur votre site à 10h46, près d'une heure avant que vous posiez votre question.

Si vous visitez votre site par le protocole https:// et que vos feuilles de styles CSS, vos images, vos scripts JS etc sont toujours appelés explicitement en http:// seul, le navigateur Internet refusera d'afficher ce contenu "non sécurisé". Il vous faut vérifier vos liens et privilégier les liens relatifs et sans protocole (pour utiliser celui actuellement utilisé).


P8OdseCN.gifVous avez une question ?

Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, utilisez alors dans ce cas le formulaire de contact pour me joindre.

Hors ligne

#4 28/12/2016 12:08:15

lejardindesroses
Membre
Inscription : 21/02/2015
Messages : 5

Re : [Résolu] Piwik - affichage de l'interface

Bonjour,
en effet nous avons activé la prise en charge SSL de notre site préalablement à notre question. Mais le problème été déjà récurrent :
Nous devions mettre à jour notre version PHP (ce que nous avons fait hier également) pour pouvoir passer à la version 3.0 de piwik. De fait nous pensions que c'était ce retard qui posait problème. Nous nous en sommes occupé hier, mais visiblement cela n'a pas résolu le problème.

Voici une capture d'écran : https://www.lejardindesroses.pro/upload … 1482921773

En tout cas, le site internet ne semble pas en cause car il fonctionne très bien, et sa base de donnée n'est pas du tout conséquente. Mais je souhaitais avoir votre avis sur le problème au cas où une erreur de manip de ma part aurait eu lieu.
Mais je penche plus pour un problème chez piwik. Peut-être que la solution serait de réinstaller piwik tout simplement.

Merci .

Hors ligne

#5 28/12/2016 12:37:57

elodie
Responsable/CEO FranceServ Hébergement
Lieu : Jura
Inscription : 02/04/2010
Messages : 6 883
Site Web

Re : [Résolu] Piwik - affichage de l'interface

lejardindesroses a écrit :

Depuis peu, piwik me pose un problème en ne chargeant pas les fichiers CSS de l'interface. Donc Piwik s'affiche correctement mais de manière "brut".

Est ce que ce problème est permanent ou aléatoire ?

lejardindesroses a écrit :

Lorsque j'essaye de me rendre à l'adresse indiquée, ça me demande de m'authentifier.

Soit vous me communiquez par mail à admin@franceserv.fr un identifiant afin que je puisse reproduise le problème et l'analyser, soit vous essayez vous même d'afficher la source HTML de votre page via votre navigateur Internet puis vérifiez un par un les liens menant vers les feuilles de styles CSS afin de vérifier quelle feuille ne délivre pas son contenu.

lejardindesroses a écrit :

Mais je penche plus pour un problème chez piwik. Peut-être que la solution serait de réinstaller piwik tout simplement.

C'est également possible mais le mieux serai d'essayer de comprendre le problème dans un premier temps.


P8OdseCN.gifVous avez une question ?

Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, utilisez alors dans ce cas le formulaire de contact pour me joindre.

Hors ligne

#6 31/12/2016 15:10:48

lejardindesroses
Membre
Inscription : 21/02/2015
Messages : 5

Re : [Résolu] Piwik - affichage de l'interface

elodie a écrit :
lejardindesroses a écrit :

Depuis peu, piwik me pose un problème en ne chargeant pas les fichiers CSS de l'interface. Donc Piwik s'affiche correctement mais de manière "brut".

Est ce que ce problème est permanent ou aléatoire ?

Oui ce problème est permanent.

elodie a écrit :
lejardindesroses a écrit :

Lorsque j'essaye de me rendre à l'adresse indiquée, ça me demande de m'authentifier.

Soit vous me communiquez par mail à admin@franceserv.fr un identifiant afin que je puisse reproduise le problème et l'analyser, soit vous essayez vous même d'afficher la source HTML de votre page via votre navigateur Internet puis vérifiez un par un les liens menant vers les feuilles de styles CSS afin de vérifier quelle feuille ne délivre pas son contenu.

Je vous communique par mail les identifiants.

Hors ligne

#7 31/12/2016 15:28:22

elodie
Responsable/CEO FranceServ Hébergement
Lieu : Jura
Inscription : 02/04/2010
Messages : 6 883
Site Web

Re : [Résolu] Piwik - affichage de l'interface

lejardindesroses a écrit :

Je vous communique par mail les identifiants.

Mail reçu et je vous ai répondu immédiatement après.

Je me suis alors connectée à votre interface d'administration et j'ai pu voir une première page qui me semble correcte à l'affichage.

Communiquez moi s'il vous plait l'adresse exacte ou sur quel lien je dois cliquer dans le menu pour rencontrer votre problème.


P8OdseCN.gifVous avez une question ?

Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, utilisez alors dans ce cas le formulaire de contact pour me joindre.

Hors ligne

#8 04/01/2017 18:04:39

lejardindesroses
Membre
Inscription : 21/02/2015
Messages : 5

Re : [Résolu] Piwik - affichage de l'interface

elodie a écrit :

Communiquez moi s'il vous plait l'adresse exacte ou sur quel lien je dois cliquer dans le menu pour rencontrer votre problème.

Voici le lien que nous utilisons : http://www.lejardindesroses.pro/piwik/

Hors ligne

#9 04/01/2017 18:23:07

elodie
Responsable/CEO FranceServ Hébergement
Lieu : Jura
Inscription : 02/04/2010
Messages : 6 883
Site Web

Re : [Résolu] Piwik - affichage de l'interface

lejardindesroses a écrit :
elodie a écrit :

Communiquez moi s'il vous plait l'adresse exacte ou sur quel lien je dois cliquer dans le menu pour rencontrer votre problème.

Voici le lien que nous utilisons : http://www.lejardindesroses.pro/piwik/

D'accord, c'est bien là où j'étais. Comme dit dans le mail du 31/12, je ne vois pas de problème d'affichage sur cette page.

Désactivez alors vos éventuelles extensions anti-pub, videz le cache de votre navigateur et vos cookies ou essayez avec un autre navigateur Internet.


P8OdseCN.gifVous avez une question ?

Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, utilisez alors dans ce cas le formulaire de contact pour me joindre.

Hors ligne

#10 05/01/2017 12:27:42

lejardindesroses
Membre
Inscription : 21/02/2015
Messages : 5

Re : [Résolu] Piwik - affichage de l'interface

elodie a écrit :

Désactivez alors vos éventuelles extensions anti-pub, videz le cache de votre navigateur et vos cookies ou essayez avec un autre navigateur Internet.

Ça y est le programme se charge de nouveau complètement.
En effet, c'était bien le bloqueur de pub qui empêchait le CSS de se charger, ce qui me semble curieux mais qui, je suppose, ne vous étonnera pas. En tout cas je ne m'en serait pas douté.

Merci encore pour votre aide et pour le temps que vous nous avez consacré.

Hors ligne

Pied de page des forums

[ Générées en 0.031 secondes, 9 requêtes exécutées - Utilisation de la mémoire : 716.38 Kio (pic d'utilisation : 880.59 Kio) ]