[Terminé] Abandon de la branche 5.4 de PHP

Les annonces officielles de FranceServ Hébergement.
Avatar du membre
Elodie
Messages : 7721
Enregistré le : 2 avril 2010 à 20:14

Bonjour,

Après l'abandon de la branche 5.3, c'est maintenant au tour de la branche 5.4 d'être abandonnée.

La branche 5.4 de PHP qui était encore proposée aux hébergés chez FranceServ Hébergement va être abandonnée dans 30 jours le 10/03/2018 et retirée des versions PHP proposées par FranceServ Hébergement dès maintenant pour les nouveaux sites.

Cette version n’est plus maintenue par les équipes de développement chez PHP depuis près de 3 ans et cette situation constitue un trop grand risque pour la sécurité des sites concernés ainsi que celle de l’infrastructure de FranceServ Hébergement pour ne pas agir.

Un mail automatique vas être envoyé aujourd'hui aux hébergés concernés avec la procédure à suivre pour changer la version PHP de leurs sites. Je recommande la version 7.0 de PHP ou au minimum la version 5.6.

Rappel : Pour changer la version PHP de votre site, connectez-vous dans un premier temps sur votre interface de gestion à l’adresse https://www.franceserv.fr/ puis dans l'encadré « Mes sites » cliquez sur l’icône représentant une roue dentée en face de l’adresse du ou des sites concernés dans l’encadré. Vous trouverez alors dans l’onglet « Options PHP » la version PHP à utiliser pour votre site. Je recommande la version 7.0 de PHP ou au minimum la version 5.6. Validez ensuite votre modification, elle sera prise en compte dans les 5 minutes.

Comme toujours, pensez à maintenir à jours vos sites Internet afin de suivre l'évolution informatique et prévenir les failles de sécurité.

La branche 5.4 de PHP ne sera plus fonctionnelle dans 30 jours le 10/03/2018, les sites qui n’auront pas été migré sur une autre version PHP se verront placés automatiquement sur la version 5.6 de PHP.

Pour information, les branches PHP 5.5, 5.6, 7.0 et 7.1 sont disponibles chez FranceServ Hébergement : https://phpinfo.franceserv.fr

La branche 5.5 de PHP disparaitra à son tour 1 mois après l'abandon de la branche 5.4, vous serez avertis comme vous l'avez été pour les version 5.3 et 5.4 de PHP au moment voulu avec un délai de 30 jours minimum.

Si vous avez des questions, n’hésitez pas à me contacter.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Fsb1
Messages : 3
Enregistré le : 17 novembre 2012 à 23:11

Bonjour

je viens de migrer de la version 5.4 à 7, mais ma page "contact reservation" ne fonctionne plus, je remplie les champs et je ne reçois plus d'email? pas d'erreur sur mon site.

Pouvez m'aider, car n'étant pas informaticien je risque d'avoir de grosses difficulté?

Cordialement
Avatar du membre
Elodie
Messages : 7721
Enregistré le : 2 avril 2010 à 20:14

Bonjour,
fsb1 a écrit :je viens de migrer de la version 5.4 à 7, mais ma page "contact reservation" ne fonctionne plus, je remplie les champs et je ne reçois plus d'email? pas d'erreur sur mon site.
Quelle solution Web utilisez-vous, Wordpress, Joomla, etc ? Avez-vous essayé de passer en 5.6 au lieu de la 7 directement ? Car l'écart de version entre la 5.4 et 7 est très importante.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Fsb1
Messages : 3
Enregistré le : 17 novembre 2012 à 23:11

bonjour,

j'ai fais mon site en code HTML, CSS et PHP, je viens de basculer en 5.5 et cela fonctionne, en 5.6 le site fonctionne mais avec des warnings. le 5.6 sera en ligne combien de temps?

Merci
Avatar du membre
Elodie
Messages : 7721
Enregistré le : 2 avril 2010 à 20:14

fsb1 a écrit :j'ai fais mon site en code HTML, CSS et PHP, je viens de basculer en 5.5 et cela fonctionne, en 5.6 le site fonctionne mais avec des warnings. le 5.6 sera en ligne combien de temps?
D'accord.

La branche 5.6 est maintenue par l'équipe de développement de PHP jusqu'au 31/12/2018 concernant sa sécurité. Elle sera retirée de la production quelques semaines après cette date.

La branche 5.5 est terminée depuis le 21/07/2016 et sera abandonnée chez FranceServ Hébergement dans 2 mois minimum, une fois que la branche 5.4 sera retirée.

Voici les liens officiels chez PHP avec l'ensemble des dates :

https://secure.php.net/supported-versions.php
https://secure.php.net/eol.php
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Domidom81
Messages : 67
Enregistré le : 10 avril 2012 à 18:58

Bonjour,
J'ai testé la version 7 et 5.6 PHP que j'ai actuellement je me retrouve sur mon site avec des "?" un peu partout sur les pages ?
http://meteo-lagarrigue-81090.franceser ... raison.php

Une idée ou solution !
Merci beaucoup.
Avatar du membre
Elodie
Messages : 7721
Enregistré le : 2 avril 2010 à 20:14

Bonjour également,
domidom81 a écrit :J'ai testé la version 7 et 5.6 PHP que j'ai actuellement je me retrouve sur le mon site avec des "?" un peu partout sur les pages ? http://meteo-lagarrigue-81090.franceser ... raison.php
Je ne vois pas de problème d'accent sur votre site, il est indiqué dans son entête qu'il faut utiliser le Latin1 via le code "charset=iso-8859-1" et mon navigateur à bien sélectionné cet encodage.

Où ne voyez-vous pas ces accents ? Essayez dans un premier temps de vider le cache de votre navigateur Internet et forcez le chargement de votre page à l'aide de la combinaison des touches "Ctrl+F5" au besoin.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Cavril
Messages : 2
Enregistré le : 7 avril 2015 à 22:55

elodie a écrit :Bonjour également,
domidom81 a écrit :J'ai testé la version 7 et 5.6 PHP que j'ai actuellement je me retrouve sur le mon site avec des "?" un peu partout sur les pages ? http://meteo-lagarrigue-81090.franceser ... raison.php
Je ne vois pas de problème d'accent sur votre site, il est indiqué dans son entête qu'il faut utiliser le Latin1 via le code "charset=iso-8859-1" et mon navigateur à bien sélectionné cet encodage.

Où ne voyez-vous pas ces accents ? Essayez dans un premier temps de vider le cache de votre navigateur Internet et forcez le chargement de votre page à l'aide de la combinaison des touches "Ctrl+F5" au besoin.
Bonjour, il y a un souci d'accent en effet, peut être que l'encodage du fichier n'est pas le bon, car lorsqu'on visualise la source, les caractères sont aussi altérés. Il faut que le fichier soit encodé utf-8.

Peut être que la solution utilisée pour transférer le fichier doit être aussi configurée, essayer le transfert binaire si filezilla est utilisé.
Jeanne-santoni
Messages : 4
Enregistré le : 8 février 2013 à 15:31

bonjour
je ne vois pas la roue dentée....?
Avatar du membre
Elodie
Messages : 7721
Enregistré le : 2 avril 2010 à 20:14

jeanne-santoni a écrit :je ne vois pas la roue dentée....?
C'est cette icône :

Image
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Répondre