[Résolu] problème police d'écriture

Vous avez un soucis dans la création, la retouche graphique ou dans votre feuille de style ? Un problème dans la manipulation de Gimp ou de Photoshop ? Ou encore mieux, des réponses à apporter ? C'est par là.
Répondre
Electronic100
Messages : 174
Enregistré le : 13 avril 2012 à 20:53

Bonjour,

J'ai un très gros problème, j'ai défini les polices dans le fichier CSS, mais cela ne fonctionne pas. J'ai vérifier tout mais tout les liens.

Voici l'adresse du fichier CSS : http://electronic100.franceserv.com/Fichiers/Design/CSS/style.css
Des polices : http://electronic100.franceserv.com/Fichiers/Design/Fonts/segment14/

Quel est le problème ?

Merci d'avance
@+
Inconnu
Messages : 6464
Enregistré le : 29 décembre 2010 à 18:15

Réessaye en enlevant les guillemets autour de l'url.
Electronic100
Messages : 174
Enregistré le : 13 avril 2012 à 20:53

où ça ?
Avatar du membre
Elodie
Messages : 7769
Enregistré le : 2 avril 2010 à 20:14

Voilà comment je procède :

Code : Tout sélectionner

@font-face
  {
  font-family: "Tahoma-fsh";
  src: url('/fonts/tahoma.ttf');
  }
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Inconnu
Messages : 6464
Enregistré le : 29 décembre 2010 à 18:15

En fait il y a une erreur de syntaxe ligne 10 dans ta CSS. Il y a une accolade fermante au lieu d'une accolade ouvrante.
Avatar du membre
Elodie
Messages : 7769
Enregistré le : 2 avril 2010 à 20:14

jeremyvn a écrit :En fait il y a une erreur de syntaxe ligne 10 dans ta CSS. Il y a une accolade fermante au lieu d'une accolade ouvrante.
Bien vu ;)
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Inconnu
Messages : 6464
Enregistré le : 29 décembre 2010 à 18:15

Il faut que je fasse une page wiki sur "Comment débugger ses scripts".

Rien qu'avec Firefox et les outils de dev qui y sont intégrés, on peux faire pas mal de choses notamment voir les styles qui s'appliquent aux élément, cibler précisément un élément, voir les erreurs, etc.
Inconnu
Messages : 6464
Enregistré le : 29 décembre 2010 à 18:15

Mettre un H1 dans un P je ne trouve pas ca très logique.

Ce que tu peux faire à la rigueur c'est mettre une classe sur ton H1 :

Code : Tout sélectionner

<h1 class="titre">Le Site Electronic100 est en construction</h1>

Code : Tout sélectionner

.titre {
    font-family: 'titre', Arial, serif;
}
Ou mettre ton contenu dans une div avec une classe dessus :

Code : Tout sélectionner

<div class="titre">
    <h1>Le Site Electronic100 est en construction</h1>
    <br>
    <progress value="48" max="100"></progress>
</div>

Code : Tout sélectionner

.titre  h1{
    font-family: 'titre', Arial, serif;
}
Electronic100
Messages : 174
Enregistré le : 13 avril 2012 à 20:53

cela fonctionne !

mille merci !

@+

PS : je ne trouve pas le bouton pour mettre en Résolu
Inconnu
Messages : 6464
Enregistré le : 29 décembre 2010 à 18:15

Il n'y en a pas ^^
Met "Résolu" dans le titre de ton topic si tu peux encore l'éditer.
Répondre