Installation Apache 2.4.2

Si vous avez des suggestions sur nos services, n'hésitez pas à nous en parler ici.
Inconnu
Cet utilisateur a supprimé son compte et n’existe plus.
Messages : 6340
Inscription : 29 décembre 2010 à 18:15

Bonjour,
J'envisage d'installer en local easyPHP 12.1 sur mon PC pour tester des routines PHP.

Je suis étonné de constater que vous êtes encore avec Apache 2.2 2 sur votre serveur alors que easyPHP propose Apache 2.4.2.

Y-t-il de grosses différences entre les deux versions et éventuellement la raison de rester sous apache 2.2.2?

Cordialement
gilbertlesne
Avatar de l’utilisateur
Tilde3
Messages : 461
Inscription : 19 octobre 2011 à 13:11
Contact :

Jusqu'au 21 août, la dernière version stable d'Apache était la 2.2.22. Elle est depuis passée en 2.4.3; sachant que la branche 2.4.x est une nouvelle génération.

Je n'y connais rien, mais j'imagine que :
  • Quand on est hébergeur, on évite de faire un upgrade trop récent.
  • Qu'il ne suffit pas d'un `apt-get upgrade apache2' pour que tout roule.
  • Que l'upgrade est peut-être prévue, mais que cela exige d'évaluer l'intérêt des nouvelles fonctionnalités, de lire la doc…
Avatar de l’utilisateur
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7931
Inscription : 2 avril 2010 à 20:14

Bonsoir,

En effet, le wraper suPHP (qui assure les protections et chroot PHP pour exécuter les scripts PHP/MySQL) est incompatible avec la nouvelle branche d'Apache 2.4.x et bien que certaines personnes ont sorties des patchs sur des pastebin non officiels, c'est encore trop risqué et je n'ai pas encore essayé sur une machine de laboratoire.

De plus, l'écriture des fichiers .htaccess est différente sur certaines directives comme le "order deny,allow". Les développeurs de Drupal indiquent par exemple les modifications à apporter (http://drupal.org/node/1599774) car l'installation de ce CMS bug totalement sous un Apache 2.4 et il y a surement beaucoup d'autres CMS impactés.

Au moment de la sortie de la nouvelle branche de PHP 5.4, j'ai dû mettre en place dans l'interface de gestion la possibilité de choisir entre la dernière version PHP et une version de la branche précédente car certains sites ne fonctionnaient plus du tout.

Au niveau d'Apache, il est impossible de proposer 2 versions différentes, sinon beaucoup trop lourd pour l'utilité que ça apporte pour le moment. Avoir la dernière version d'Apache n'apporte pas autant que d'avoir la dernière version de PHP.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Inconnu
Cet utilisateur a supprimé son compte et n’existe plus.
Messages : 6340
Inscription : 29 décembre 2010 à 18:15

Bonjour Elodie,

Merci pour tes explications toujours aussi claires.

J'ai le choix entre EasyPHp et Wampserver et je constate que Wampserver reste sur la version 2.2.2 de Apache (bien qu'il propose une version 2.4.2 en 64bits)

J'ai la possibilité de tester les routines directement sur mon espace FTP disponible mais comme dans un premier temps, j'ai l'intention de récupérer des routines sur des sites web, je crois qu'il est peut-être plus prudent de les tester en local.

On ne peut pas avoir de garantie à 100% qu'une routine téléchargée ne soit pas vérolée...

cordialement
gilbertlesne
Verrouillé