PRESTASHOP 1.7.7.1 PROBLEME DE MISE A JOUR FRONT

Quelque chose ne fonctionne pas alors qu'il vous semble que le soucis ne vient pas de vous ? Vous avez des questions sur nos services et vous pensez que vos préoccupation peuvent intéresser d'autres hébergés ? N'hésitez pas à nous contacter.
Répondre
Cbaccino
Messages : 26
Enregistré le : 30 janvier 2021 à 16:43

Bonsoir Elodie

J'ai un problème de mise à jour de mon site.
Toutes les modifications effectuées dans le backend prestashop ont été saisies mais rien ou peu apparait désormais.
Ce que j'ai essayé de faire.
- par ftp renommer les dossiers prod et dev dans /www/www.selectionad.com/var/cache/
- désactiver dans l'administration l'utilisation d'un cache
J'ai vidé les caches de mes navigateurs et utiliser par exemple le navigateur de mon smarthphone

aucun changement.
ce qui devrait apparaitre :
- mes modifications de la page d'accueil
- modification sur le menu déroulant à gauche ( Décoration intérieure devrait apparaître)

Pourtant rien ne se modifie malgré la validation du backend.
Comment expliquer çà ?
hier soir j'ai modifier la version de la branche php obsolète 7.3 pour passer en php 7.4.x
J'ai fait une saisie dans le module html personnalisé de la page d'accueil fourni par prestashop après enregistrement la page reste inchangée sur le frontend
Par curiosité, je suis revenu en 7.3 pour voir et ai revalidé mes changements. Le Front-end reste inchangé !

Une idée ? Please help !....
Modifié en dernier par Cbaccino le 11 mai 2022 à 07:12, modifié 2 fois.
Cbaccino
Messages : 26
Enregistré le : 30 janvier 2021 à 16:43

9:16. Via FTP, j'ai supprimé les deux dossiers dev et prod dans le dossier var/cache
J'ai supprimé tous les caches de mes navigateurs.
Toujours même problème
Avatar du membre
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7822
Enregistré le : 2 avril 2010 à 20:14

Bonjour,

Ce que vous me décrivez et comme vous l'avez apparemment constaté (en changeant de navigateur Internet), ça ressemble à un problème qui apparait côté client. Ça peut être un problème de compatibilité navigateur ou d'extension navigateur, d'un antipub ou proxy/antivirus...). Ça peut être également un problème de développement Prestashop ou d'un de ses modules (officiel ou non), d'un modèle éventuel ou d'une de ses extensions.

Sinon d'après le tableau de compatibilité Prestashop/PHP, pour une version PS 1.7.7.1 il vous faudrait rester sur la branche PHP 7.3 discontinuée :

https://devdocs.prestashop.com/1.7/basi ... lity-chart

Il vous faudrait alors essayer un autre navigateur/autre machine et essayer de mettre à jour votre Prestashop à la version 1.7.8.x afin de bénéficier possiblement d'un correctif de ce genre (et pouvoir migrer sur PHP 7.4). Vous devriez poser votre question sur le forum de Prestashop car c'est un problème lié avec leur solution et il y a probablement un autre de leurs utilisateurs qui a déjà été confronté à ce problème.

Sinon, je connais un expert développeur Prestashop qui vous conseillerai même de rétrograder sur Prestashop 1.6 (avec un de ses patchs pour le rendre compatible PHP nouvelle version) parce que la 1.7 serai connue pour avoir des problèmes de bases. En tant que sys-admin réseau, je ne pourrai pas vous aider plus que ça.

Par contre, si vous avez d'autres questions ou un besoin de l'hébergeur dans vos échanges sur le forum de Prestashop, n'hésitez pas à m'indiquer l'URL où je pourrai suivre la discussion afin que je participe aux vérifications si nécessaires avec leur communauté.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Répondre