Activation

Quelque chose ne fonctionne pas alors qu'il vous semble que le soucis ne vient pas de vous ? Vous avez des questions sur nos services et vous pensez que vos préoccupation peuvent intéresser d'autres hébergés ? N'hésitez pas à nous contacter.
Répondre
Lovpuppy
Messages : 192
Enregistré le : 11 avril 2012 à 13:56

Bonjour
Je dois installer un CMS sur m.d---.com
Au debut de l'installation voilà le message d'erreur reçu :

Les exigences suivantes manquent :

Veuillez activer/ajouter la fonction : exec()
Veuillez activer/ajouter la fonction : exec()
PHP ini `max_input_time` doit être >= à `300`

Comment puis je regler ça ?
Lovpuppy
Messages : 192
Enregistré le : 11 avril 2012 à 13:56

J'ai trouve l'activation d' ()exec
Maintenant le message est :

Les exigences suivantes manquent :

Veuillez activer/ajouter le binaire : zip
Veuillez activer/ajouter le binaire : unzip
Veuillez activer/ajouter le binaire : wget
PHP ini `max_input_time` doit être >= à `300`
Avatar du membre
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7836
Enregistré le : 2 avril 2010 à 20:14

Bonjour,

Je viens d'autoriser les binaires systèmes zip, unzip et wget sur le serveur Web (même si ces fonctions étaient déjà exploitables via PHP et ses modules) et j'ai rechargé vos permissions afin que vous puissiez les utiliser dès maintenant.

Concernant la configuration PHP ini, vous pouvez apporter ces modifications à l'aide du fichier ".user.ini" qu'il vous faut placer à la racine de votre site Internet (en plaçant par exemple la ligne suivante : max_input_time=300).
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Lovpuppy
Messages : 192
Enregistré le : 11 avril 2012 à 13:56

Merci Elodie
Toutefois le message est toujours là !

Les exigences suivantes sont manquantes :

Veuillez activer/ajouter le binaire : zip
Veuillez activer/ajouter le binaire : unzip
Veuillez activer/ajouter le binaire : wget
Avatar du membre
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7836
Enregistré le : 2 avril 2010 à 20:14

Je vous ai également activé le binaire "which" car votre solution Web s'appuie dessus pour vérifier ses binaires. Vous pouvez alors réessayer.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Lovpuppy
Messages : 192
Enregistré le : 11 avril 2012 à 13:56

Ca se gâte :

Impossible d'extraire le package. Veuillez vérifier que la fonction exec n'est pas désactivée et les autorisations de votre dossier d'installation SiberianCMS.
Avatar du membre
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7836
Enregistré le : 2 avril 2010 à 20:14

Je pense qu'il va vous falloir vous diriger vers la documentation et/ou le support de l'éditeur de la solution que vous tentez d'installer, car de mon côté ces fonctions sont bien actives et les permissions sur votre espace FTP sont également correctes.

Par contre, le fichier ZIP que votre installateur a téléchargé contiens étrangement dans son contenu, une arborescence avec l'utilisateur root/root ce qui n'est vraiment pas du tout recommandé pour un service Web et qui n'est pas possible chez un hébergeur Web (hormis un serveur dédié et même là ce n'est pas du tout recommandé).

Vous pouvez tenter de dézipper vous-même le fichier ZIP pour aider l'installation et envoyer le tout via FTPs/SFTP/Rsync.

Sinon, je pense qu'il vous faudrait vérifier ce détail chez l'éditeur de votre solution Web.
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Avatar du membre
Elodie
Fondatrice / Responsable
Fondatrice / Responsable
Messages : 7836
Enregistré le : 2 avril 2010 à 20:14

En vérifiant les prérequis de votre solution, ils disent que votre solution ne fonctionne pas en hébergement mutualisé et qu'il vous faudrait un serveur dédié : "Type of server: Virtual Private Server (VPS) or Dedicated Server (no Shared servers)" source : https://doc.siberiancms.com/knowledge-b ... uirements/
Vous avez une question ? Posez-la de préférence sur le forum et si ça demande un contact plus instantané, n'hésitez pas à vous rendre sur le t'chat IRC. Si votre question est personnelle, contactez-nous directement.
Répondre